WordPress-Mailpress远程代码执行漏洞

0x00 介绍
Mailpress是一个比较流行的邮件插件。
Plugin Directory:https://wordpress.org/plugins/mailpress/
官网:http://blog.mailpress.org
此漏洞已于2016年06月21日通报给wordpress。

0x01 漏洞简述
Mailpress存在越权调用,在不登陆的情况下,可以调用系统某些方法,造成远程命令执行。

0x02 漏洞详细
文件:
mailpress\mp-includes\action.php

转到:
mailpress\mp-includes\class\MP_Actions.class.php
即可以调用 MP_Actions.class.php 文件中任意方法。
其中:
autosave方法是添加邮件内容
我们来重点看看

注意到代码:

转到 do_eval

因此,subject参数造成远程命令执行

0x03 漏洞利用

1
1

原文链接:,转发请注明来源!

发表评论

要发表评论,您必须先登录